[XFA] RM Marketplace (shop) - XF2

xF2 Add-on [XFA] RM Marketplace (shop) - XF2 4.3.4

No permission to download
E

es-xenforo.com

Guest
ENXF NET updated [XFA] RM Marketplace (shop) - XF2 with a new update entry:

Bug fixes, modifications and new features

WARNING:
The pdf invoice library has been changed in this version, please follow our manual for installation insrtuctions HERE.

Corrected bugs:
  • TypeError: Argument 3 passed to XFRM\Template\TemplaterSetup::fnResourceIcon() must be an instance of XFRM\Entity\ResourceItem, null given src/addons/XFRM/Template/TemplaterSetup.php:7
  • Renew license button doesn't show before...

Read the rest of this update entry...
 

Pr0fesseur

Well-known member
Registered
Joined
Nov 20, 2019
Messages
69
Points
18

Reputation:

found it :)

still trying to get this thing to work though.......
followed the FAQ everything works in sandbox but not in live...

set my paypal api creds correctly, i have a business account, but still errors that "Error initializing paypal communication"

i have percentage on sale at 0.00 and the email in percentage on sale is empty for categories
 

icewarrior

SVIPS Member
S.V.I.P.S Member
Joined
Feb 14, 2020
Messages
13
Points
3

Reputation:

yeah i have business account too, once i put in my api credentials everything worked, if you dont mind me asking where did you place the PPConfiguration file
 

Pr0fesseur

Well-known member
Registered
Joined
Nov 20, 2019
Messages
69
Points
18

Reputation:

root pf internal_data
just as faq requests

ERROR
```
Array
(
[TIMESTAMP] => 2020-05-03T17:28:28Z
[CORRELATIONID] => 3f63023cc5723
[ACK] => Failure
[VERSION] => 97.0
[BUILD] => 54520512
[L_ERRORCODE0] => 10002
[L_SHORTMESSAGE0] => Security error
[L_LONGMESSAGE0] => Security header is not valid
[L_SEVERITYCODE0] => Error
)
```


1588527207487.png
1588527244374.png
1588527321381.png
 
Last edited:

icewarrior

SVIPS Member
S.V.I.P.S Member
Joined
Feb 14, 2020
Messages
13
Points
3

Reputation:

yeah that is a strange error, i'm going to be doing a fresh install of xenforo sometime tonight so i will see if i can replicate the error
 

Pr0fesseur

Well-known member
Registered
Joined
Nov 20, 2019
Messages
69
Points
18

Reputation:

(y)
Guess I'm stuck for now...

been working on this for days now and nothing seems to work....

In the PPconfiguration.php remember to set the lofg to true and the path somewhere you can find the logs


According to paypal the error is the credentials are wrong, but i cant for the life of me see how?
 

Pr0fesseur

Well-known member
Registered
Joined
Nov 20, 2019
Messages
69
Points
18

Reputation:

OK UPDATE

So the error was my email address has a + symbol in it...

DONT use an email with a + symbol in it... ugh working now!
 
E

es-xenforo.com

Guest
Can you take a picture of the error if it fails to load
 

legendsehi

Well-known member
Registered
Joined
Aug 21, 2019
Messages
189
Points
43

Reputation:

here, after user purchase the addon download button is gone!received_2548913465437610.jpeg
 
Top